Videoer fra brugermødet d. 8 marts kan nu ses her[.

pythonfejl ved brug af kortforsyningen og datafordeler plugin

Alt om plugins i QGIS. Måske er der brug for underkategorier her?
Lars Christensen
Indlæg: 3
Tilmeldt: tors 10. mar 2016 14:13

pythonfejl ved brug af kortforsyningen og datafordeler plugin

Indlægaf Lars Christensen » ons 30. maj 2018 11:54

Jeg får en fejl når jeg forsøger at tilknytte temaer fra kortforsyningspluginnet eller datafordelerpluginnet.

jeg har forsøgt at afinstallere/geninstallere plugin og jeg har forsøgt at geninstallere QGIS...

fejlen opstår i QGIS 2.18.20, - men har også installeret QGIS 3.0 og OSGeoW4 pakken.

fejlen ser ud som følger:

Traceback (most recent call last):
File "C:/Users/larcht/.qgis2/python/plugins\Kortforsyningen\kortforsyningen.py", line 156, in <lambda>
kf_helper = lambda _id: lambda: self.open_kf_node(_id)
File "C:/Users/larcht/.qgis2/python/plugins\Kortforsyningen\kortforsyningen.py", line 222, in open_kf_node
layer = self.open_node(node, id)
File "C:/Users/larcht/.qgis2/python/plugins\Kortforsyningen\kortforsyningen.py", line 225, in open_node
QgsProject.instance().read(node)
File "C:/Users/larcht/.qgis2/python/plugins\profiletool\apicompat\qgsproject.py", line 55, in read
return original_QgsProject_read(self, QFileInfo(filename))
TypeError: arguments did not match any overloaded call:
QFileInfo(): too many arguments
QFileInfo(QString): argument 1 has unexpected type 'QDomNode'
QFileInfo(QFile): argument 1 has unexpected type 'QDomNode'
QFileInfo(QDir, QString): argument 1 has unexpected type 'QDomNode'
QFileInfo(QFileInfo): argument 1 has unexpected type 'QDomNode'



jeg får ikke lagene tilknyttet!
Fejlen optræder kun på min pc, min kollegas pc virker ok

Nogen der har prøvet noget lignende og har en løsning?

mvh Lars C
0 x
JetteBælum
Indlæg: 1
Tilmeldt: man 11. jun 2018 12:09

Re: pythonfejl ved brug af kortforsyningen og datafordeler plugin

Indlægaf JetteBælum » man 11. jun 2018 12:11

Jeg får nøjagtig samme fejl, så er nysgerrig efter at se en løsning :-)
0 x
Christoffer Nielsen
Indlæg: 1
Tilmeldt: tirs 12. jun 2018 09:33

Re: pythonfejl ved brug af kortforsyningen og datafordeler plugin

Indlægaf Christoffer Nielsen » tirs 12. jun 2018 09:35

Optræder fejlen kun i QGIS 2.18 eller også i QGIS 3?
For så kunne det evt. være fordi Kortforsyningen har opdateret pluginnet, så det ikke længere er kompatibelt med gamle QGIS-versioner.
0 x

Social Media

       

Tilbage til "Plugins"

Hvem er online

Brugere der læser dette forum: Ingen og 0 gæster